Backup via smb on port 445 does not work

Discussion in 'LiquidFiles General' started by ChrisV, May 4, 2021.

Tags:
  1. ChrisV

    ChrisV New Member

    Joined:
    May 4, 2018
    Messages:
    8
    Likes Received:
    0
    Hello,

    i try to use Liquidfiles backup to a Windows Server which is only available via port 445 through DMZ-firewall restrictions.
    This is normally working good from other devices in our DMZ but is not working from Liquidfiles.
    Anyway, if i log on to Liquidiles console and do a
    ---------------------
    [root@files ~]# smbclient -L //192.168.XXX.XXX -p 445 -U MyUser@MyDomaine
    ------------------------
    i got a the list of all shares on that server.

    But anyway, no backup is created when doing a
    ------------------------------------
    [root@files ~]# ft backup
    Backup Proto (smb/sftp/ftp): || smb
    Backup Share: || //192.168.XXX.XXX/Backup-Liquidfiles
    Username: || MyUser@MyDomaine
    Password: xxxxxxxxxxxxxxxxxxxxxxxxx
    Directory (without filename): ||
    Backup Filename (don't add suffix, .tgz will be appended): 2021-05-04_Liquidfiles-Config
    Backup both Config and Data (Y) or just Config (N)?
    N
    Running backup job... Filename: 2021-05-04_Liquidfiles-Config-config.tgz
    -------------------------------

    • I also did not find any log-file that containes info about the smb backup process at all. Where is the smb-log?
    • Can someone tell me if Liquidfiles backup works with smb2 or smb3 at all? Can i set the used smb-protocoll version somewhere?
    • Is port 445 enough or did i need 136,137 also?
    • Did i address a server with "\\" or "//"? Both are not throwing a error.
    • In fact, how did you manage to get a manual backup working?
     
  2. David

    David Administrator
    Staff Member

    Joined:
    Dec 1, 2015
    Messages:
    784
    Likes Received:
    31
    Try to configure the initial backup in the Admin GUI (Admin > System > Backup), you will see more details what's exactly wrong from there after you hit the Save button. The backup host should be listed like \\10.20.30.40\sharename
    LF appliance will not allow save the Bk configuration until it can connect to the remote SMB server and store a test file (backup_testfile.xxxxx).
     
  3. ChrisV

    ChrisV New Member

    Joined:
    May 4, 2018
    Messages:
    8
    Likes Received:
    0
    Thanks for your answer,

    but, how's about port & smb-protocoll version? No idea?
    Unfortunatly even it does not save my setting (which probably mean no connection), it does not throw any error and gives me no info at all why it is not saving.
     
  4. David

    David Administrator
    Staff Member

    Joined:
    Dec 1, 2015
    Messages:
    784
    Likes Received:
    31
    The connection related issues are displayed on the top in a red frame after you hit the Save button.
    But there can be also syntax errors i.e. in the SMB hostname configuration or forbidden characters in the password or in the Bk directory path.
    These errors with short description are displayed under the particular filed where is something wrong.

    When you are using a DNS resolvable name or direct IP address of the Bk server, then you will be fine only with the TCP/445 port.
    The ports 137-139 for NetBios resolution are not needed.

    LF starts to negotiate the connection with the Bk server from the newest SMB protocol. So it will try at first with SMB3 and so on.
     

Share This Page