ClamAV service not running.

Discussion in 'LiquidFiles General' started by chill, Oct 18, 2018.

  1. chill

    chill New Member

    Joined:
    Oct 18, 2018
    Messages:
    1
    Likes Received:
    0
    I'm finding that all of the messages in liquidfiles are not being virus scanned and are just showing this under messages:

    File1.pdf (is being scanned for viruses, please check back in a little while. 0 in queue)

    I've tried to force update the AV:

    [rootuser@liquidfiles ~]$ sudo ft av_update
    [sudo] password for rootuser:
    Do you want to remove the existing AV signatures (only do this if there's a problem)? y
    Removing previous signatures.
    ClamAV update process started at Wed Oct 17 13:38:41 2018
    Downloading main.cvd [100%]
    main.cvd updated (version: 58, sigs: 4566249, f-level: 60, builder: sigmgr)
    Downloading daily.cvd [100%]
    daily.cvd updated (version: 25044, sigs: 2124495, f-level: 63, builder: neo)
    Downloading bytecode.cvd [100%]
    bytecode.cvd updated (version: 327, sigs: 91, f-level: 63, builder: neo)
    2018/10/17 13:42:21.236672 INFO Agent WALinuxAgent-2.2.32.2 launched with command 'python -u bin/WALinuxAgent-2.2.32.2-py2.7.egg -run-exthandlers' is successfully running
    2018/10/17 13:42:21.479100 INFO Event: name=WALinuxAgent, op=Enable, message=Agent WALinuxAgent-2.2.32.2 launched with command 'python -u bin/WALinuxAgent-2.2.32.2-py2.7.egg -run-exthandlers'is successfully running, duration=0
    Database updated (6690835 signatures) from clamav.liquidfiles.com (IP: 13.32.123.232)

    Do you want to force-restart the AV engine (ClamAV)? y
    Job for clamd.service failed because the control process exited with error code. See "systemctl status clamd.service" and "journalctl -xe" for details.
    Restarted.
    [rootuser@liquidfiles ~]$ systemctl status clamd.service -l
    ● clamd.service - clamav daemon
    Loaded: loaded (/usr/lib/systemd/system/clamd.service; enabled; vendor preset: disabled)
    Active: failed (Result: start-limit) since Wed 2018-10-17 13:42:46 UTC; 14s ago
    Process: 3595 ExecStart=/usr/sbin/clamd (code=exited, status=1/FAILURE)

    Oct 17 13:42:46 some.website.com systemd[1]: clamd.service: control process exited, code=exited status=1
    Oct 17 13:42:46 some.website.com systemd[1]: Failed to start clamav daemon.
    Oct 17 13:42:46 some.website.com systemd[1]: Unit clamd.service entered failed state.
    Oct 17 13:42:46 some.website.com systemd[1]: clamd.service failed.
    Oct 17 13:42:46 some.website.com systemd[1]: start request repeated too quickly for clamd.service
    Oct 17 13:42:46 some.website.com systemd[1]: Failed to start clamav daemon.
    Oct 17 13:42:46 some.website.com systemd[1]: Unit clamd.service entered failed state.
    Oct 17 13:42:46 some.website.com systemd[1]: clamd.service failed.

    But the clamAV service will not start.

    What can I do?
     
  2. Johan

    Johan Administrator
    Staff Member

    Joined:
    Dec 1, 2015
    Messages:
    32
    Likes Received:
    1
    If you haven't yet updated to LiquidFiles v3.2.12, you will need to do so to fix this issue. You can update in the web interface by going to Admin → System → Update or by logging in on the console and running the command `ft update`.

    In a recent ClamAV update, the RedHat/CentOS team decided to move the ClamAV configuration file and the new system default configuration file is not compatible with LiquidFiles. For security reasons, LiquidFiles automatically updates ClamAV as part of the nightly maintenance, and this update is what caused this issue. Updating to LiquidFiles v3.2.12 uses the new ClamAV default configuration location and will make the system fully functional again.
     

Share This Page