Liquidfiles & Azure

Discussion in 'LiquidFiles General' started by Martin Preishuber, Jan 29, 2017.

  1. Martin Preishuber

    Martin Preishuber New Member

    Jan 29, 2017
    Likes Received:

    I just installed Liquidfiles 3.0.8 in Azure and as it is kinda challenge to do that, I thought I'd share my experience.

    Attempt 1:

    I took the VHD file provided at the download page, uploaded it to Azure, created a new VM. Creation failed, because dynamic VHDs are not allowed.

    Attempt 2:

    I edited the VHD in a local Hyper-V server and converted it to a fixed VHD, repeated the excercise from my first attempt, the creation of the VM timed out.

    Attempt 3:

    Actually not a real attempt - I tried to run a VM with the VHD file locally, which failed as well. It booted, but was stuck on the CentOS progress screen. The grey bar filled fully up to the right side and then nothing more happened.

    Attempt 4:

    I created a local VM by installing Liquidfiles via the ISO image, that worked pretty well. As the whole exercise is a test for migrating our existing 2.6 installation I created a trial license - just to find out, that SSH is not allowed in the trial license. So I had to use the production license to enable SSH to perform the preparation of the VM for Azure (see: ). Then again I uploaded the VHD file (note: static VHD! no dynamic VHD, no VHDX!), re-created the VM and then it was working just fine.

    Bottom line(s) of the whole story:

    • The VHD file seems to be really tricky to use, at least I didn't manage to get it to work properly (on a Windows 2012 R2 Core server with Hyper-V)
    • It would be very convenient, if Liquidfiles people would provide a ready-to-use Azure VHD file - or even better, put it directly in the Azure Gallery (or whatever the "store" for new VMs is named)
    Best regards,


Share This Page