VirusScanner 0 in queue

Discussion in 'LiquidFiles General' started by solidtso, Oct 17, 2018.

  1. solidtso

    solidtso New Member

    Joined:
    Oct 17, 2018
    Messages:
    6
    Likes Received:
    0
    Hello LiquidFiles.

    Up until yesterday, our server running liquidFiles was running without any problems. But to people are not able to send files, they get a message saying that the files are being scanned and they are "0 in queue"

    I found another thread with the same issue but the solution did not work for me :(

    i ran:
    cd /app/current
    ft update (picked the newest version has it told me to do)
    ft av_update (and i choose to remove existing av signatures)
    ft avscan_all_files

    But the problem is still there:
    (is being scanned for viruses, please check back in a little while. 0 in queue)

    This is the error for the log
    7 Oct 13:07 liquidfiles err VirusScan Error: while scanning:
     
    #1 solidtso, Oct 17, 2018
    Last edited: Oct 17, 2018
  2. Johan

    Johan Administrator
    Staff Member

    Joined:
    Dec 1, 2015
    Messages:
    38
    Likes Received:
    1
    If you haven't yet updated to LiquidFiles v3.2.12, you will need to do so to fix this issue. You can update in the web interface by going to Admin → System → Update or by logging in on the console and running the command `ft update`.

    In a recent ClamAV update, the RedHat/CentOS team decided to move the ClamAV configuration file and the new system default configuration file is not compatible with LiquidFiles. For security reasons, LiquidFiles automatically updates ClamAV as part of the nightly maintenance, and this update is what caused this issue. Updating to LiquidFiles v3.2.12 uses the new ClamAV default configuration location and will make the system fully functional again.
     
  3. solidtso

    solidtso New Member

    Joined:
    Oct 17, 2018
    Messages:
    6
    Likes Received:
    0
    Hello Johan,

    Did you not read my post? I did run the ft update command.
    Also, the web interface is on autoUpdate all files. There are no available updates there.
    That might be because the version I'm running is v3.2.11 (there is no 3.2.12 available for me) Is it a beta release?

    Again here is what I tried so far:
    cd /app/current
    ft update (picked the newest version has it told me to do)
    ft av_update (and I choose to remove existing av signatures)
    ft avscan_all_files

    As of now, I have disabled the antiVirus so my users can send files again.

    But thanks for explaining what is causing the problem.
     
  4. David

    David Administrator
    Staff Member

    Joined:
    Dec 1, 2015
    Messages:
    702
    Likes Received:
    15
    if there is no available update on the list, then you are most probably already updated on v3.2.12. Please check the version on top bar in the Admin GUI.
     
  5. solidtso

    solidtso New Member

    Joined:
    Oct 17, 2018
    Messages:
    6
    Likes Received:
    0
    There seem to be a version mismatch here.
    upload_2018-10-19_10-50-46.png
     
  6. Justinian

    Justinian New Member

    Joined:
    Oct 20, 2018
    Messages:
    1
    Likes Received:
    0
    Johan,

    Thank you for this solution. FT Update, updating and rescanning did the trick for me. Much appreciated.
     
  7. Little Bobby Tables

    Little Bobby Tables New Member

    Joined:
    Oct 24, 2018
    Messages:
    1
    Likes Received:
    0
    Thanks for this! Suppose I were not able to update to 3.2.12, for reasons that don't need exploring at this juncture. Am I correct in thinking that this problem could also be solved on the console by creating a symlink from the old ClamAV configuration file location to the new location? If so, does anyone know what those two locations are?
     
  8. David

    David Administrator
    Staff Member

    Joined:
    Dec 1, 2015
    Messages:
    702
    Likes Received:
    15
    Easiest is to install the official patch in the LF v3.2.12, but if you don't want to update right now, you can either create a symlink or
    overwrite the default scan.conf with LF's clamd.conf:
    mv /etc/clamd.conf /etc/clamd.d/scan.conf

    then restart clam service:
    systemctl restart clamd
    systemctl status clamd

    and finally re-scan the affected files:
    ft avscan_all_files
     

Share This Page